Start a new topic
Solved

Updated modules, error in PricingModule

I updated some modules through the update module ui. And ended up with error when trying to access the admin site.


My attempt to fix error was, delete all modules and create new database. After the auto install module section of a fresh start I still have the error.


The error is:

Method 'CreatePrices' in type 'VirtoCommerce.PricingModule.Data.Services.PricingServiceImpl' from assembly 'VirtoCommerce.PricingModule.Data, Version=2.11.0.0, Culture=neutral, PublicKeyToken=null' does not have an implementation.


My platform version is latest dev. Looking at master of the pricing module repo, I see there is no method called CreatePrices.


:Sigve


You able to downgrade Core.Module to 2.15.1?  In admin modules UI?


All pages in /admin result in the exception.

Could you make reinstall as you did before?

Got Core 2.15.1 this time, but still the same error.

Going home now, can try more tomorrow.

Remove all from platfrom/App_Data/Modules and all should works

Thanks it works now.

Login or Signup to post a comment