Start a new topic
Answered

Installed locally and something is amiss...

Followed the docs here: Getting Started Guide but when I run, I get an IS error saying that it "Cannot read configuration file"


Yes, I have set permissions and changed the Read-Only flag on the files.



And IIS structure:


What on earth could I be forgetting?




Best Answer

Yeah, team viewer is fine as well. I have one already installed.


Issue was wrong connection string to the database which for some reason caused screen to just hang without displaying any error messages.


Can you attach screenshot of the error you are getting?


Here is the same issue on MS forums: https://forums.iis.net/t/1157959.aspx.


The basic issue is that you use network mapped drive and should instead use network path "\\path\asdasd" since otherwise IIS won't be able to see mapped drive that is only done for your local session. All that assuming you are using network storage.

Ok, I set to the physical directory.  Now I'm getting this:


Server Error in '/admin' Application.Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive.

Source Error: 

Line 56:     </appSettings>
Line 57:     <system.web>
Line 58:         <compilation debug="true" targetFramework="4.5.1" />
Line 59:         <!-- 50MB in kilobytes, default is 4096 or 4MB-->
Line 60:         <httpRuntime targetFramework="4.5.1" maxRequestLength="512000" />


Source File: C:\Users\eshipman\Documents\Source Control\VirtoCommerce\PLATFORM\VirtoCommerce.Platform.Web\web.config    Line: 58 

Version Information: Microsoft .NET Framework Version:2.0.50727.5485; ASP.NET Version:2.0.50727.5491

Removed the targetFramework attributes and getting this now:


Server Error in '/admin' Application.Could not load file or assembly 'CacheManager.Core' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.BadImageFormatException: Could not load file or assembly 'CacheManager.Core' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

You shouldn't remove target framework and it looks like you don't have the latest Microsoft .NET Framework 4.5.1.

I have VS2015 installed, it installed 4.5.1 by default.

Then maybe IIS app pool is not configured to use the latest version. Can you check?

In trying to set the framework version for the App pool, it doesn't have a 4.5.1 in the dropdown, only 2.0.50727 and 4.0.30319.


Looks like IIS 7/5/7600/16385 that was installed with Win7 Sp1. Should I upgrade IIS Express?

.net version 4.0 will do just fine when selecting it for app pool. Also no need to update to IIS Express, IIS is better.

It is already set o the 4.0.30319 version.

BTW, I do have 4.51 framework installed.

Do you still get "Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive." error when web.config is not modified?

Login or Signup to post a comment