Start a new topic
Answered

Search is not working

Finally got the site running, but can't go past the front page.

Error 

"Search is not working"

We're sorry. The search is not working now.
Go to Home Page.

Best Answer
Use VS 2012.

 


Can you give us the url to your site, and search service url like: http://url-search.cloudapp.net:9200?
The most probable cause is that index is missing, and that could be because scheduler is not installed or not working.

 

http://mpesewa-search.cloudapp.net/

Seems like http://mpesewa-search.cloudapp.net:9200 does not open at all. Is it correct url? Also can you check if such service exisit and is running under cloud services in https://manage.windowsazure.com/#Workspaces/CloudServicesExtension/list

 

Yes the URL is correct

all 3 services are created and running under Azure cloud services


David, we found the issue with a search. We'll be releasing an updated package shortly.

Here is what you need to do:


  1. Download the file attached and overwrite the source code package with the files in the archive.
  2. Delete all azure services and storage account you created.
  3. Re-run the deploy.ps1.

Let us know how it works!
zip

Sorry the hotfix did not work.


http://mpesewa-search.cloudapp.net:9200

I just download the latest code from codeplex, copied over the patch and ran the deploy.ps1. I have a site with a running search:

http://mpesewatest-www.cloudapp.net/

http://mpesewatest-search.cloudapp.net:9200/


It looks like your search is not working at all. Here is what i would do:


  1. Open the storage account in azure called "mpesewa", go to containers tab and delete the following containers: "esworkerrole-in-0", "messages-blob", "taskscheduler-container".
  2. Open deploy.ps1 and find a section called "# advanced options" and set it to be the following (it will now only re-deploy search and scheduler, which will be much faster since you already have a db):

# advanced options
$build = "True"
$deploydatabase = "False"
$deploysearch = "True"
$deployfrontend = "False" 
$deployscheduler = "True" 
$deployadmin = "False"


Hope this helps.

Search is still not running

see below



Warning WAT170


The warnings are fine, they are because configs container link to local development environment for the azure storage, which are replaced by connection string to the real storage account during deployment.


The search worker role worked before, so the reason it is probably not working is because it can't access a storage account, can you check if you have a storage named "mpesewa" with a container "esworkerrole-in-0".


Also check and post the log files for ES Worker Role, to do that do the following:


1. Open VS.NET 2012.
2. Open Server Explorer and Expand Windows Azure, find your deployment (you can import deployments if you don't have any).


3. Right click on the instance and select "Update Diagnostics Settings", in the popup dialog change log level to all and save.


4. Reboot the ESWorker role from the azure management console.

5. Go back to the screen shown in step 3, right click the instance and pick "view diagnostics data", expand "windows azure application logs" and click view all data. Copy and paste messages you retrieved.


You can also send us access key to the storage account "mpesewa" and we can see the logs ourselves.



PS: also instead of troubleshooting this errors you can simply change the $service_prefix to a new value, lets say add "0" at the end and run full deployment again.

Тоже самое на новой версии, как лечится?

 

i got the same problem , how can i fix it???

Answer
Use VS 2012.

 

Login or Signup to post a comment